r — conda: PackagesNotFoundError: The following packages are not available — Stack Overflow

Conda: packagesnotfounderror: the following packages are not available

There is a json file in every conda repo directory, containing all package info. In my case, the error is directly related to that json file content.

I was using UCST repo mirror, and disabled official repo due to connectivity issues. After reenabling official repo, the error is gone.

Afterwards, by comparing the content of the mirror’s json file and official repo’s json file. It is clear the mirror’s json file is messed up. so does the directory content. Not sure if UCST has fixed it or not.

That’s it.

Deb (уголок новичка, софт, управление пакетами) / поиск по тегам / русскоязычное сообщество manjaro linux

Для работы нужна электронная подпись. Ключ — USB флешка. Для подписания документов нужна программа КриптоПро CSP 4.0 R3 — она есть в deb и rpm. В АУРЕ нет. Точно нет. Да искал. Нет не нашел.

, собственно как я понял архив. Распаковываем, и видим кучу .deb пакетов и файл install.sh

Открываем install.sh и видим, то ли лицензию, то ли предупреждение и, как я понял (честно — не понял) инструкцию на исполнение установки, или как это называется

.

И собственно вопрос, как мне из всего этого собрать пакет для установки программы?

Method 2: use the error prompt, enter the annaconda website and use the command to solve

When adding the above statement, there is still an error, and when installing a certain python package (not particularly for a specific package, this situation sometimes occurs in various packages. The current channel is unavailable, and an error is reported:

PackagesNotFoundError: The following packages are not available from current channels:

The complete display of the error:

Packagesnotfounderror: the following packages are not available from current channels. how to solve?

It looks like some of the subversions of the packages in the requirements file were built for PyPi distribution, but not conda. Also, some of the package names for PyPi use dashes, but they use underscores on conda.

This can be fixed by loosening the subversion in the requirements files and replacing some of the dashes with underscores.

Some of the packages have different names as well. For instance Torch is called pytorch. Also, the you will need to include the pytorch channel.

Lastly, the valuedispatch package is only on PyPi, and will have to installed using PIP.

Replace the requirements file with the on below, and then run the following commands:

conda conda install -y --file requirements.txt -c defaults -c conda-forge -c pytorch
pip install valuedispatch
pip install profiling

requirements.txt:

appdirs==1.4.*
astroid==2.3.*
attrs==19.3.*
autopep8==1.5.*
backcall==0.1.*
black==19.*
bleach==3.1.*
certifi==2022.11.*
chardet==3.0.*
click==7.1.*
click-default-group==1.2.*
ConfigArgParse==1.2.*
configparser==5.0.*
cycler==0.10.*
Cython==0.29.*
decorator==4.4.*
deepdish==0.3.*
defusedxml==0.6.*
entrypoints==0.*
faiss-cpu==1.6.*
faiss-gpu==1.6.*
h5py==2.10.*
hdbscan==0.8.*
idna==2.*
ipykernel==5.2.*
ipython==7.13.*
ipython_genutils==0.2.*
ipywidgets==7.5.*
isort==4.3.*
jedi==0.16.*
Jinja2==2.11.*
joblib==0.14.*
jsonschema==3.2.*
jupyter==1.0.*
jupyter_client==6.1.*
jupyter_console==6.1.*
jupyter_core==4.6.*
kiwisolver==1.2.*
lazy-object-proxy==1.4.*
llvmlite==0.31.*
MarkupSafe==1.1.*
matplotlib==3.2.*
mccabe==0.6.*
mistune==0.8.*
mypy==0.*
mypy_extensions==0.4.*
nbconvert==5.6.*
nbformat==5.0.*
notebook==6.0.*
numba==0.48.*
numexpr==2.7.*
numpy==1.18.*
opencv==4.2.*
pandas==1.0.*
pandocfilters==1.4.*
parso==0.6.*
pathspec==0.8.*
pexpect==4.8.*
pickleshare==0.7.*
Pillow==7.1.*
prometheus_client==0.7.*
prompt_toolkit==3.0.*
protobuf==3.11.*
ptyprocess==0.6.*
pycodestyle==2.5.*
Pygments==2.6.*
pylint==2.4.*
pyparsing==2.4.*
pyrsistent==0.16.*
python-dateutil==2.8.*
pytz==2022.*
PyYAML==5.3.*
pyzmq==19.0.*
qtconsole==4.7.*
QtPy==1.9.*
regex==2020.5.*
requests==2.23.*
scikit-learn==0.22.*
scipy==1.4.*
seaborn==0.10.*
Send2Trash==1.5.*
six==1.14.*
pytables==3.6.*
tensorboardX==2.*
terminado==0.8.*
testpath==0.4.*
toml==0.10.*
pytorch==1.4.*
torchvision==0.5.*
tornado==6.0.*
tqdm==4.45.*
traitlets==4.3.*
typed-ast==1.4.*
typing-extensions==3.7.*
umap-learn==0.3.*
urllib3==1.25.*
urwid==2.1.*
wcwidth==0.1.*
webencodings==0.5.*
widgetsnbextension==3.5.*
wrapt==1.11.*

Alternatively, you could probably install everything using PIP and the original file via:

pip install -r requirements.txt

But as @merv mentioned, it is best to not do this in the base environment.

Оцените статью
ЭЦП64
Добавить комментарий